iOS: Version 9 or later (Compatible with iPod touch, iPhone and iPad) Download


Android*: Version 4.1 or later Download
*Only Android devices with Google Mobile Services natively installed are supported


App Language:

  • English
  • Traditional Chinese
  • Simplified Chinese 
  • Japanese
  • Arabic
  • Spanish
  • Italian